FAQ n°13544, publiée le 19/09/2016, mise à jour le 10/10/2016
WINDEV MOBILE
Quelle version de Xcode utiliser pour la compilation des applications avec WINDEV Mobile 21 Update 3 ?
Les projets Xcode générés par WINDEV Mobile 21 jusqu'à sa version Update 3 (210065N) étaient adaptés à la Xcode 7 (7.3.1) en vigueur.

Depuis la diffusion de WINDEV Mobile 21 Update 3, Apple a publié Xcode 8. Cette nouvelle version a nécessité des changements dans la génération des projets Xcode, notamment pour la gestion des signatures. Les adaptations nécessaires sont disponibles dans un pack de mise à jour de WINDEV Mobile 21. 

La version de Xcode à utiliser avec WINDEV Mobile 21 Update 3 (210065N) est donc la version 8 en installant le pack dédié suivant :



Si le test d'une application iOS doit être fait ponctuellement depuis un poste équipé de WINDEV Mobile 21 Update 3 sur lequel le pack WM210PACKIOS065n n'a pas encore pu être téléchargé, il faut utiliser Xcode 7 (7.3.1).


Si une application était publiée sur l'AppStore après sa compilation par Xcode 8 sans que WINDEV Mobile 21 ne dispose du pack WM210PACKIOS065n, le warning suivant serait retourné par Apple :
"This app attempts to access privacy-sensitive data without a usage description"


Autres liens sur le sujet :